New post
0

DR750S-2CH Not Recording / No LiveView

Hi all,

For a couple of years, I've had my DR750S-2CH running happily with a Samsung 64GB EVO+ SD card (U1, Class 10). Recently the card failed, becoming unwritable, both in the camera and on my PC. The camera drew my attention to the problem with its "Check SD Card" notification. I expect cards to fail from time-to-time so no issues, I'll just replace it.

I have attempted to replace the card with a SanDisk Ultra 64GB A1 U1 Class 10 and with a SanDisk Extreme 128GB A2 U3 V30. In both cases, the camera is able to format the card, but does not record any video.

If I attempt to use LiveView through the mobile app, without being logged into BlackVue Cloud, it firstly displays a grey screen, after a few seconds the screen turns white, then pops up the message "Network connection failed". After a few seconds more, the camera reboots and connection is lost.

If I attempt to use LiveView through the mobile app, whilst being logged into BlackVue Cloud, the camera tells me that its starting LiveView but after about 20 seconds it pops up a "LiveView failed" message.

Note, the camera firmware version is 1.0.20, and that all other functions of the camera work perfectly. The camera is hardwired using power magic pro.

Can anyone advise on what I should do next to resolve my issue?

Thanks in advance,

Joe

12 comments

  • 1
    Avatar
    Joe Parkin

    For the benefit of the community, I'm posting the chat response from Blackvue here:

    Jane: Hi, good day from BlackVue!
    Please check your sd card match the information below.
    And you need to format sd card first with PC and then re-load firmware. 
    Please don't do it with app because we need to check the sd card status.
    SD card considerations
    1. The SD card should be at least Class 10 or U1 (Minimum serial data is 10MB/s) for it to be able to handle Full HD video recording.
    ​​
    2. If the SD card is not fast enough, this may cause the dashcam to re-start as the card cannot keep up with the amount of data being written to it.
    We suggest using a Blackvue SD card as most 3rd party SD cards are not designed for dashcam use can and cause quite a few issues. Most 3rd party SD cards are not suitable for FULL HD loop recording as the heat can drastically reduce the write speed, causing the SD card to be unresponsive and the camera restarting.
    You can use the Find a store option on our website for you to find a distributor, dealer, or installer in your region.
    https://www.blackvue.com/store-finder
    In case you can’t get a Blackvue SD card then please check out the following article about SD card recommendations for dashcams posted by a dashcam reviewer:
    https://carcamcentral.com/guide/recommended-microsd-cards-for-dash-cameras
    *Please note that we can’t guarantee the best performance of any third-party SD card including the ones mentioned in the article in BlackVue dashcams.
    *The BlackVue SD cards have a six-month warranty period so you can contact the seller for the replacement of the faulty BlackVue SD card within the warranty period.
    *It is recommended to format the SD card once a week or in two weeks to avoid any operational issues of the SD card.
    Please do the following steps to re-install / upgrade the firmware using a PC (factory reset/troubleshooting) and see if it will resolve the issue.
    1. Download the BlackVue PC Viewer.
    * For Windows Users: https://www.blackvue.com/download/blackvue-windows-viewer-cloud/
    * For MAC Users: https://www.blackvue.com/download/blackvue-mac-viewer-cloud/
    2. Turn off the dashcam and take out the SD card. Connect it with the computer by using the micro SD card reader.
    3. After getting the backup of your necessary recordings saved on the SD card, format it as FAT32 [Windows] / MS-DOS(FAT) [MAC] using the format tool in BlackVue PC Viewer program (please refer to the attached pics).
    4. Download the latest firmware for your dashcam model from our website:

        https://www.blackvue.com/downloads/#1460710341510-e242903f-5343

    5. Unzip the downloaded firmware and copy the "BlackVue" folder into the SD card.
    6. Insert SD card to BlackVue device and turn on the camera for upgrading firmware.
    (Caution: Please do not turn off the power during the firmware upgrading and you will have a message when upgrading is completed.)


    Video tutorial for Windows:
    https://drive.google.com/open?id=1xwsK7ihZ2J2HZsAaaveHupKcur6bek3s
    Video tutorial for MAC:
    https://drive.google.com/open?id=1iNdQlDvQIufoDcOTx4lhKXMFAdra9LcZ
    https://drive.google.com/open?id=1LTFuw5ASd2nREuVZne6jY1wF4OegIzi3
    If the issue persist, I recommend to revert firmware to the previous version.
    Regarding live view issue, please let me know the wifi hotspot for cloud connection.
    re-install firmware with PC is the first step to resolve the issue. and re-configure wifi hotspot connection is the 2nd step.
    Please let me know after testing.
    Thank you.
    Regards
    Jane

  • 1
    Avatar
    John Atkins

    Any news on this? I tonight have encountered the same issue. I do have one other piece of information that might help. When I was updating the app it told me there was a new firmware update so I went to apply it (1.020). When it was applying it told me not to disconnect power, etc. However, after 20mins it still hadn't finished. I had to disconnect the power as the update had obviously failed. When I connected the power again it did the update again, then rebooted, etc. At that time I wanted to check the camera position, and that was when I noticed that live view, recording, etc wasn't working. I suspect that the update may have broken the dashcam.

  • 0
    Avatar
    Brentlyl

    I have the exact same issues as Joe Parkin.  The first sign of a problem was the "Check SD Card" notification.  Word for word everything Joe says is EXACTLY what is happening to me and many others as I have discovered while trying to resolve the camera's problems.  My camera is hardwired using power magic pro, exactly as Joe Parkin's camera is.

    When using the Windows desktop Cloud Web Viewer, I can connect and access the camera settings etc.,  but there are no recordings (the camera is NOT recording, not even manual recordings even though the voice announcement says it is), and when I try Live View it never shows the main camera like it used to BUT... when I switch to the rear camera it does connect! There is no way I can see to switch to the rear camera via the mobile app in this scenario but can do that with the Web Viewer on my PC. 

    Even using a BlackVue SD card, it does not matter.  I've tried everything, different cards, older firmware but no matter what these problems exist.  They exist when connected to my house WiFi and I connect through the cloud.  They exist when I connect directly to the camera's WiFi. I do not see how "re-configuring the wifi hotspot", as you suggest above, would have anything to do with our cameras NOT RECORDING ANY VIDEO AT ALL.  Even without all these connection issues, when you take the card out of the camera and put it in the card reader the RECORD folder is empty.  There is obviously a problem with our cameras or aspects of a later firmware on our cameras that isn't being replaced when an older firmware is applied because all of us would not be experiencing the exact same problems.  The problem for us is not the SD cards we're using, it's not our networks. This is the second camera that has not reliably performed and it's very aggravating.  PLEASE fix this.  

  • 0
    Avatar
    garry cooke

    Has there been any out come into fixing this issue. I was on the verge of purchasing a new dashcam thinking my existing one was broke until I read what Brentlyl wrote although I did purchase an expensive Blackvue SD card to know avail.

    What I am experiencing is word for word what Brentlyl has put. Can anyone please advise me. Thanks Garry

  • 0
    Avatar
    Joe Parkin

    Garry,
    I lost all patience with Blackvue customer service and the unit's diagnostics weren't helping, therefore, I've dumped my Blackvue unit and switched to a competitor.
    Thanks,
    Joe

  • 0
    Avatar
    garry cooke

    Thanks for your response Joe. Just waiting to here back from Blackvue and see if they have come up with an easy fix at all.  Your response sounds quite technical if someone isn't the best with computers.

  • 0
    Avatar
    garry cooke

    This is the response I eventually got back from Blackvue :-

    Hi, Thank you for choosing BlackVue! Have you tried to view the recordings using the Dashcam's Wi-Fi so we can determine if the issue is on the cloud part. Please check the following steps to view the recordings using the camera Wi-Fi connection. 

    1. Go to your BlackVue App, Select Continue as Guest. If you are logged in, log out your account first.
    2. Click Connect to Wi-Fi Camera. Minimize the Blackvue App.
    3. Go to your phone settings, Wi-Fi connection and connect to the Blackvue Network using the wi-fi password.
    4. Go back to the Blackvue App, Click Continue.
    5. Click Playback to view the recordings.

     Regards,Blackvue Support Team

    I had no luck at all with this. Feel like giving up.  Although this problem seems to be all of a sudden quite common with the DR750s - 2CH. If anyone else has had the same issues and any success with a fix please, please share your finds otherwise I am resigned to thinking the camera is now faulty even though I have had it only 3 years and it is just out of warranty.

  • 0
    Avatar
    James Hawkins

    I have had a DR750S-2CH for 6 years. I am experiencing the same problems. I noticed the unit taking longer to start normal recording and then the SD card errors. I completed all the steps mentioned here and still no video. Since I do not check the feed clips on a regular basis, I suspect the unit failed recording before the SD card failure.

    What to do? Find a different brand!

  • 0
    Avatar
    SR

    Hey Everyone,

    I'm running into the same exact issue that Joe had mentioned.    Everything was working fine (I think) until I upgraded the firmware to 1.0.20.  

    I say 'I think' because now I'm not so sure the camera was recording when it was on the older firmware.    On 1.0.20 it shows its recording, but when I check the SD card, nothing there.   Also, live view goes grey, then white, then network connection error.    

    I can't seem to find any of the old firmware anywhere online to see if I can roll it back.   Did anyone actually get a resolution to this issue?  Very frustration and I am thinking of dumping blackvue after having 4 different models. 

  • 0
    Avatar
    John Atkins

    Contact their support. I did, and they refurbed the unit for me - fixed the issue. I am still pretty sure that the issue was related to the firmware update that failed.

  • 0
    Avatar
    SR

    Yeah, they want $90 to $120 to RMA the unit to Korea.    I'm just going to buy the Garmin 67w for the front and use an old blackvue that I have for the rear.  

  • 0
    Avatar
    Blackvue750S-82C519

    Bei meiner das selbe Problem mit der neuen Software.

    Sollte das von der Firma extra einen Crash verursachen, damit man eine neue kauft?

    Kommt mir so vor....

Please sign in to leave a comment.