New post
0

No audio prompts; can't change camera settings

Hello,

I have a DR750S-2CH in my wife's car.  Recently, I noticed that I am no longer getting voice prompts for anything.  In the process of troubleshooting that, it seems that I also can't make any settings changes to the camera.  More info on each here:

Voice prompts:  This came about because I tried to put a new 128 GB SD card into the camera in place of the old 64 GB card.  When I powered on the camera, the GPS and Wi-Fi LEDs would just flash forever.  I expected to hear something like "Check SD Card," but the camera said nothing.  When I put the old 64 GB card back in, it powered up and started recording as usual. 

Settings Changes:  With the 64 GB card back in, I went into the settings to see if maybe something got turned off by mistake.  I didn't see anything unusual, but I changed a couple of voice settings anyway and then saved them.  After saving the changes, I expected the camera to reboot and reformat the SD card, as it always does when I made settings changes.  But it didn't... no voice message, no reboot.  It just kept on recording as if nothing happened.

I also have a DR900S in my own car.  Today, I received a 256 GB card and went to put it in the camera to replace the 128 GB card that had been in there.  (The DR900S takes up to 256 GB; the DR750S can only handle 128 GB.)  When I put the 256 GB card in, as soon as I powered the camera on, it started saying "Check SD Card" over and over, as I would expect.  I pressed and hold the side button, it beeped, and prompted me to press and hold the button again for 5 seconds to format the SD card.  I did that, and it's happy.

That made me think perhaps I could try the button with the DR750.  I took the 128 GB card that I had removed from the DR900S and put it into the DR750S and powered it on.  It powered up and started recording, presumably because the card was already formatted for use in a Blackvue camera.  But just to see what would happen, I pressed and held the side button for 5 seconds.  No beep, no prompts.  I pressed and held it again, and the camera then went through the motions of formatting the SD card.  I could tell by the change in LED status, but again, no voice prompts.  After it came back up, I took the advice I saw on another forum post and tried re-flashing the firmware.  It was already on 1.020, the latest version, but I installed it again.  It went through the motions and rebooted a couple of times, then came back up... but again, no voice prompts, no "Please do not disconnect the power," nothing like that.

At this point, since I don't get voice prompt AND I can't make settings changes, I'm wondering if my camera is bad.

Thanks!

0 comments

Please sign in to leave a comment.