New post
0

BlackVue DR650GW-2CH Total failure after firmware upgrade

Thanks in advance if anyone can help...

So today I decided to format my SD card because my cam had been rebooting itself a bit lately. I have done a lot of successful formats and upgrades over the years across numerous cams and other devices and would consider myself handy technically. Today I formatted the SD card a couple of times (without changing firmware - I was on 2.008), and each time when I plugged the power in, it went through the initialisation process etc without issue, and everything worked fine. I say that because I struggle to believe that there was suddenly a power cable issue.

I then realised that there was a new firmware... having been discontinued for so long, I was surprised to see a firmware that I missed, but needless to say, I was happy to upgrade. I was upgrading via the Blackvue PC viewer on windows. The format seemed to go ok, and then copying across the files seemed ok, and then I changed a few setting on the SD card while in the Viewer app before putting into the dashcam as I normally do (timezone, etc). 

Only issue this time was that when I plugged it back in, no lights came on. I only had the car in accessories mode, so just in case, I turned the ignition fully on, but that didn't help. I tried turning the car off and on, and I tried unplugging and replugging the cam in, but that made no difference at all.

Any ideas? I will of course find a way to check the power cord, but I just don't believe that is the issue. I will try going back to the last functioning firmware (2.008) to see if that makes a difference, although if I'm correct, the camera is still at that firmware because nothing happened when I plugged the cam in this last time.

I really don't want to buy another camera just yet!

0 comments

Please sign in to leave a comment.